IMPORTANT: Per accedir als fitxer de subversion: http://acacha.org/svn (sense password). Poc a poc s'aniran migrant els enllaços. Encara però funciona el subversion de la farga però no se sap fins quan... (usuari: prova i la paraula de pas 123456)

Router 1841

Seguint les passes de l'article IP Aliasing:

$ sudo ifconfig eth0:1 10.10.10.2 netmask 255.255.255.248

Entrem a Firefox i posem la següent URL:

http://10.10.10.1
  • Usuari: cisco
  • Paraula de pas: cisco

NOTA: És molt possible que sigui necessari desactivar el bloqueig de finestres emergents (pop-ups) del vostre navegador.

La primera pàgina és simplement una pàgina de presentació:

CiscoSDM.png

CiscoSDM1.png

CiscoSDM2.png

CiscoSDM3.png

CiscoSDM5.png

CiscoSDM6.png

CiscoSDM8.png

CiscoSDM9.png

CiscoSDM10.png

CiscoSDM11.png

CiscoSDM12.png

CiscoSDM13.png

CiscoSDM14.png

Restaurar la configuració de fàbrica del router

  • Configure/Additional Tasks/Reset to factory default

Des la la consola

Cal entrar en mode ROM, amb la seqüència de break:

Ctrl+a f

Les comandes que es poden executar en mode ROM les podeu consultar amb:

rommon 1 > ?

o

rommon 1 > help 

Per recuperar una paraula de pas:

http://mudji.net/press/index.php?p=206

Per sortir del mode ROM:

Entreu i o reset per a fer un reset.

Entreu cont command per continuar amb el procés de boot.

Recursos:

Factory defaults

enable
#erase Startup-config
#reload

Recursos:

Switch catalyst

Connexió a la consola des de Linux

Necessitem un dels cables que proporciona cisco per conectar-se al port consola (Cable serie- RJ45) i una aplicació de terminal per comunicar-se mitjançant el port sèrie. En el nostre cas utilitzarem minicom. Per instal·lar minicom:

$ sudo apt-get install minicom

Cal configurar minicom per utilitzar el port sèrie amb les característiques que ens especifiquen a Cisco:

  • Baudis: 9600
  • 8 N 1
  • Port sèrie: /dev/ttyS0

Normalment el port serie és /dev/ttyS0 però per estar segurs podeu consultar a Sistema/Preferències/'Informació del maquinari:

PortSerie1.png

Si executem:

$ minicom -s

Accedim a l'apartat

Serial Port Setup

Ens apareixen les següents opcions:

   | A -    Serial Device      : /dev/ttyS0                                |
   | B - Lockfile Location     : /var/lock                                 |
   | C -   Callin Program      :                                           |
   | D -  Callout Program      :                                           |
   | E -    Bps/Par/Bits       : 115200 8N1                                |
   | F - Hardware Flow Control : Yes                                       |
   | G - Software Flow Control : No             
                                                                      |
   |    Change which setting?  

Escollim les opcions que volem modificar per connectar al dispositiu Cisco:

  • Seleccionem A i modifiquen del Port a /dev/ttyS0
  • Seleccionem E. Apareix el següent menú:

PortSerie2.png

Configurem a 9600 8 N 1. La configuració ha de quedar de la següent manera:

   +-----------------------------------------------------------------------+
   | A -    Serial Device      : /dev/ttyS0                                |
   | B - Lockfile Location     : /var/lock                                 |
   | C -   Callin Program      :                                           |
   | D -  Callout Program      :                                           |
   | E -    Bps/Par/Bits       : 9600 8N1                                  |
   | F - Hardware Flow Control : Yes                                       |
   | G - Software Flow Control : No                                        |
   |                                                                       |
   |    Change which setting?                                              |
   +-----------------------------------------------------------------------+

Pressionem Enter per tornar al menú principal i seleccionem Save Setup as fdl.

Ara per establir la connexió només ens falta seleccionar Exit. Apareixerà un missatge:

Initializing Modem

i després, si el swithc ja esta connectat us apareixerà la consola:

switchAula1>

Si el switch esta apagat, el connecteu i podreu veure per la consola tot el procés d'arrancada del commutador:

C2900XL Boot Loader (C2900-HBOOT-M) Version 12.0(5.2)XU, MAINTENANCE INTERIM SOFTWARE                           
Compiled Mon 17-Jul-00 18:19 by ayounes                                                                         
 starting...                                                                                                    
Base ethernet MAC Address: 00:04:27:34:7b:40                                                                    
Xmodem file system is available.                                                                                
Initializing Flash...
flashfs[0]: 111 files, 3 directories
flashfs[0]: 0 orphaned files, 0 orphaned directories
flashfs[0]: Total bytes: 3612672
flashfs[0]: Bytes used: 2780160
flashfs[0]: Bytes available: 832512
flashfs[0]: flashfs fsck took 6 seconds.
...done Initializing Flash.
Boot Sector Filesystem (bs:) installed, fsid: 3
Parameter Block Filesystem (pb:) installed, fsid: 4
Loading "flash:c2900XL-c3h2s-mz-120.5.2-XU.bin"...##############################################

Aquest procés es pot "trencar" per si és necessari recuperar les contrasenyes d'un commutador. Consulteu:

Consulteu el petit manual de minicom de l'apartat següent per saber com funciona minicom.

Petit Manual de Minicom

Les comandes de minicom les podeu consultar pressionant les tecles Ctrl+A i després Z (atenció la Z sense pressionar la tecla control. Bàsicament per sortir utilitzareu la tecla X.

Break sequence

Amb Minicom és

Ctrl-a f

Que vol dir Ctrl+a junts, els deixes anar i després prems f.

Recursos:

A Cisco IOS és:

CTRL-SHIFT-6 dos cops.

Solució de problemes (TroubleShooting)

Per utilitzar el port serie cal tenir permisos. Executeu:

$ ls -l /dev/ttyS?
crw-rw---- 1 root dialout 4, 64 2008-01-11 17:30 /dev/ttyS0
crw-rw---- 1 root dialout 4, 65 2008-01-11 18:12 /dev/ttyS1
crw-rw---- 1 root dialout 4, 66 2008-01-11 18:12 /dev/ttyS2
crw-rw---- 1 root dialout 4, 67 2008-01-11 18:12 /dev/ttyS3

Com veieu per utilitzar el port serie o ets root o pertanys al grup dialout. Per saber si tenim permisos consulteu els vostres grups

$ groups
sergi adm dialout fax cdrom floppy tape audio dip plugdev scanner fuse admin vboxusers

No canvieu directament els permisos del fitxer. Es tornaran a restaurar a l'iniciar el sistema. Afegiu-vos al grup dialout:

$ sudo addgroup -a -G dialout sergi

Port Mirroring

Altres noms de Port Mirroring:

Port Mirroring, Monitoring Port, Spanning Port, SPAN port and Link Mode port

Concretament a Cisco l'anomenen:

Switched Port Analyzer (SPAN)

Per activar el Port Mirroring cal configurar el Switch amb:

# configure terminal
#
# monitor session 1 source interface fastethernet 0/2

# monitor session 1 destination interface fastethernet 0/3

!--- This configures interface Fast Ethernet 0/3 as destination port.
#
# show monitor session 1
Session 1
---------
Source Ports:
    RX Only:       None
        TX Only:       None
        Both:          Fa0/2
Destination Ports: Fa0/3
C2950#

# monitor session 1 source interface1 interface2
# monitor session 1 destination interface1 interface2

http://www-staff.it.uts.edu.au/~dcom/CiscoLessons/CCNP3v40/Module07.ppt

Recursos:

Desactivar Telnet i activar SSH

Cal generar el parell de claus:

Switch(config)# hostname host-name
Switch(config)# ip domain-name domain_name
Switch(config)# crypto key generate rsa

Configurar el servidor SSH:

Switch(config)# ip ssh version 2
Switch(config)# line vty 0 4
Switch(config-line)# transport input ssh

Cisco IOS

Manual d'inici

Consulteu:

http://pages.swcp.com/~jgentry/topo/cisco.htm

Modes

La línia de comandes de Cisco està organitzada per modes. Un usuari pot canviar de mode dins la línia de comandes i cada mode determinarà quines comandes es poden executar o no.

Per saber quines comandes tenim disponibles:

> ?

Per exemple en mode no prvilegiat (mode per defecte quan s'entra):

>?
Exec commands:
 <1-99>           Session number to resume
 access-enable    Create a temporary Access-List entry
 clear            Reset functions
 connect          Open a terminal connection
 disable          Turn off privileged commands
 disconnect       Disconnect an existing network connection
 enable           Turn on privileged commands
 exit             Exit from the EXEC
 help             Description of the interactive help system
 lock             Lock the terminal
 login            Log in as a particular user
 logout           Exit from the EXEC
 name-connection  Name an existing network connection
 ping             Send echo messages
 rcommand         Run command on remote switch
 resume           Resume an active network connection
 set              Set system parameter (not config)
 show             Show running system information
 systat           Display information about terminal lines
 telnet           Open a telnet connection
 terminal         Set terminal line parameters
 traceroute       Trace route to destination
 tunnel           Open a tunnel connection
 where            List active connections

o

>show ?

De forma similar al que passa amb una línia de comandes Unix/Linux, hi ha un mode prilegiat i un mode no privilegiat

Se sap si s'està en mode privilegiat o no depenent del prompt:

  • >: no provilegiat
  • #: privilegiat

Per exemple

Router>

o

Router#

Per activar el mode privilegiat:

>enable
Password: 
#

Per sortir del mode tenim la comanda exit:

# exit

interHi ha més modes. Per exemple el mode configuració. S'accedeix amb:

# configure
#configure
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
(config)#

O per exemple:

Router(arguments)#

They still all end with the pound sign. They are subsumed within privileged mode. Many of these modes have sub-modes of their own. Once you enter priliged mode, you have access to all the configuration information and options the IOS provides, either directly from the parent mode, or from one of its submodes.

Consultar la informació del dispositiu

En mode privilegiat, alguns exemples:

#show interfaces
#show ip protocols (no s'aplica en commutadors?)
#show ip route (no s'aplica en commutadors?)
#show ip arp 

Consulta la taula ARP:

#show ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.0.102           2   0016.3ee3.051d  ARPA   VLAN1
Internet  192.168.0.10           59   0013.4987.4066  ARPA   VLAN1
Internet  192.168.0.2             0   0030.054c.901c  ARPA   VLAN1
Internet  192.168.0.7             4   000f.fede.816c  ARPA   VLAN1
Internet  192.168.0.20            -   0007.85ca.7700  ARPA   VLAN1

Consultar l'estat d'un port del commutador

Es pot tabular.

SwitchAula4>enable
Password: 
#show interface fastEthernet 0/1
FastEthernet0/1 is down, line protocol is down (notconnect)
 Hardware is Fast Ethernet, address is 0015.fabe.5601 (bia 0015.fabe.5601)
 MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, 
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation ARPA, loopback not set
 Keepalive set (10 sec)
 Auto-duplex, Auto-speed, media type is 100BaseTX
 input flow-control is unsupported output flow-control is unsupported 
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input never, output 01:02:35, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
    1 packets input, 64 bytes, 0 no buffer
    Received 0 broadcasts (0 multicast)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast, 0 pause input
    0 input packets with dribble condition detected
    1 packets output, 64 bytes, 0 underruns
    0 output errors, 0 collisions, 2 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier, 0 PAUSE output
    0 output buffer failures, 0 output buffers swapped out

Fer un ping

> ping 192.168.0.3

Fer un traceroute

>enable
Password: 
SwitchServidors#trace 192.168.9.2

Type escape sequence to abort.
Tracing the route to 192.168.9.2

  1 192.168.0.10 8 msec 8 msec 8 msec
  2 192.168.0.2 4 msec 4 msec 4 msec
  3 192.168.9.2 8 msec 4 msec 4 msec

La escape sequence és

CTRL-SHIFT-6 dos cops.

Establir el servidor de DNS

# configure terminal
(config)#ip name-server aa.bb.cc.dd
(config)#ctrl-Z
#

Consultar els paràmetres de xarxa d'un dispositiu

Router>enable 
Password: 
Router#show run 
Building configuration... 
....................
Current configuration:      
! 
version 11.3 
service timestamps debug uptime 
................... 
interface Ethernet0 
ip address 172.17.3.192 255.255.0.0

Activar servidor HTTP

Cal entrar a la consola, activar i entrar en el mode configuració

Router>enable
Router#config
Router(config)#

Ara podeu activar el servidor HTTP amb:

Router(config)# ip http server

Per aplicar els canvis cal executar la combinació de tecles:

Ctrl+Z

Recursos:

Entrar a la configuració global

Cal entrar a la consola, activar i entrar en el mode configuració

Router>enable
Router#config
Router(config)#

Ara podeu fer els vancis que vulgueu a la configuració global. Per exemple:

Router(config)# ip http server

Per aplicar els canvis cal executar la combinació de tecles:

Ctrl+Z 

Recursos:

Consultar l'estat de la CPU

# show processes CPU
CPU utilization for five seconds: 13%/1%; one minute: 13%; five minutes: 15%
PID  Runtime(ms)  Invoked  uSecs    5Sec   1Min   5Min TTY Process 
  1         268    825920      0   0.00%  0.00%  0.00%   0 Load Meter       
  2         720       248   2903   0.00%  0.31%  0.07%   1 Virtual Exec     
  3      719720    419390   1716   0.00%  0.02%  0.00%   0 Check heaps     
...


Com mostrar la configuració

D'una interfície de xarxa:

# show run interface FastEthernet0/13

Com guardar la configuració

Els canvis i configuracions fets en una terminal cisco IOS no són permanents fins que no es guarden en un medi d'emmagatzemament. La comanda:

> enable
#show running-config
Building configuration...

Current configuration : 1291 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime 
no service password-encryption
!
hostname SwitchAula1
!
enable secret 5 Password_Xifrat
!
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
--More-- 

Us mostra la configuració dels dispositiu. Aquesta configuració és la que s'aplica en aquest moments, que no te perquè ser la configuració que s'aplica un cop acabada d'iniciar la màquina.

Per passar la configuració en execució a la configuració durant l'inici del sistema cal executar:

# copy running-config startup-config  

Recursos:

Consultar dispositius Cisco amb SNMP

Establir la localització SNMP

> enable
# configure terminal
(config)# snmp-server location Aula5

Coneixer la versió de Cisco IOS

# show version
Cisco Internetwork Operating System Software 
IOS (tm) C2950 Software (C2950-C3H2S-M), Version 12.0(5.3)WC(1), MAINTENANCE INTERIM SOFTWARE
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Mon 30-Apr-01 07:56 by devgoyal
Image text-base: 0x80010000, data-base: 0x8031A000

ROM: Bootstrap program is CALHOUN boot loader

SwitchServidors uptime is 6 weeks, 5 days, 18 hours, 44 minutes
System returned to ROM by power-on
System image file is "flash:c2950-c3h2s-mz.120-5.3.WC.1.bin"


cisco WS-C2950-12 (RC32300) processor (revision B0) with 22260K bytes of memory.
Processor board ID FOC0541W0AC
Last reset from system-reset

Processor is running Enterprise Edition Software
Cluster command switch capable
Cluster member switch capable
12 FastEthernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:07:85:CA:77:00
Motherboard assembly number: 73-5782-08
Power supply part number: NONE
Motherboard serial number: FOC054004HG
Power supply serial number: DAB05391K3W
Model revision number: B0
Model number: WS-C2950-12
System serial number: FOC0541W0AC
Configuration register is 0xF

Recursos

Commutadors Cisco

Configuració des de la aplicació web(SmartPorts)

Els commutadors Cisco es poden configurar des d'un navegador web.

Si accedim a l'apartat smarthosts podem determinar quin tipus de màquina hi ha a cada port. Per exemple si activem el mode Desktop en un port:

SmartPortsCisco.png


> enable
# show running-config
....
interface FastEthernet0/3
!
interface FastEthernet0/4
switchport mode access
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
mls qos cos override
macro description cisco-desktop
spanning-tree portfast
spanning-tree bpduguard enable
...

Si marquem l'opció Router Cisco:

SmartPortsCisco1.png

#show running-config
!
interface FastEthernet0/24
 switchport mode trunk
 switchport nonegotiate
 mls qos trust cos
 macro description cisco-router
 spanning-tree portfast trunk
 spanning-tree bpduguard enable
!

Programari lliure per a Cisco

Cisco Network Assistant

Per instal·lar aquest programa executeu l'instal·lador que heu obtingut de la pàgina web de Cisco. Per exemple:

Cisco Network Assistant. cna-windows-k9-installer-5-2-es.exe

Per començar a configurar dispositius amb CNA heu de seguir les següents passes:

Executeu l'aplicació:

CiscoNEtworkAssistant1.png

CiscoNEtworkAssistant.png

Creeu una comunitat:

CiscoNEtworkAssistant2.png

Us apareixerà el següent formulari.

CiscoNEtworkAssistant3.png

Poseu la IP del dispositiu que voleu configurar:

CiscoNEtworkAssistant4.png

Packet Tracer

Recursos:

Resolució de problemes

STP (Spanning Tree Protocol) i problemes amb multicast, broadcast, DHCP

Vegeu DRBL#Switchs_Cisco_.28Spanning_Tree_protocol.29_i_problemes_amb_Etherboot.

SmartPorts i màquines virtuals

Sembla que si s'activa la opció de determinar un port del commutador Cisco com a Màquina Desktop, aleshores les màquines virtual d'eines com Virtual Box no poden obtenir una IP de la xarxa local (si que poden funcionar amb NAT).

Consulteu Xarxes_Cisco#Configuraci.C3.B3_des_de_la_aplicaci.C3.B3_web.28SmartPorts.29

Sembla que controla que no hi hagin 2 IP en el mateix port no poden obtenir.

SmartPortsCisco.png

> enable
# show running-config
....
interface FastEthernet0/3
!
interface FastEthernet0/4
switchport mode access
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
mls qos cos override
macro description cisco-desktop
spanning-tree portfast
spanning-tree bpduguard enable
...

Recursos