IMPORTANT: Per accedir als fitxer de subversion: http://acacha.org/svn (sense password). Poc a poc s'aniran migrant els enllaços. Encara però funciona el subversion de la farga però no se sap fins quan... (usuari: prova i la paraula de pas 123456)

Introducció a la pràctica

  • El primer que creem convenient es recordar els objectius de la nostra feina a fer.

Objectius

  • Conèixer el funcionament de les VLAN. Diferènciar entre tagged i untagged. Configuració de trunks.
  • Configuració de VLANs a Linux i altres sistemes operatius com routerOS.

Esquema bàsic

Disseny 1 baucells pinyol.png
Fitxer original
  • 3 VLANS:
  • Alumnat
  • Professorat
  • Servidors
  • Les xarxes d'alumnat i professorat no s'han de veure entre si. Les xarxes d'alumnat que estan en diferents commutadors s'han de veure entre si. Tant les màquines d'alumnat com les de professorat han de veure el servidor.
  • El servidor ha de veure totes les xarxes.
  • Els rangs de xarxa de cada VLAN els escolliu lliurament. Cal però documentar-los clarament.
  • Amb wireshark escoltar els paquets de sortida del port trunk i identificar la trama amb VLAN (identificar el VLAN ID)

Material necessari

  • 3 commutadors amb suport per VLAN (routerOS).
  • Un PC amb Linux

Tasques

  • Fer les proves convenients per complir les especificacions.
  • Acabar la documentació de Linux VLAN (TODOs)
  • Documentar com configurar Linux i com fer que els canvis de VLANs siguin permanents modificant fitxers de configuració

Introducció a VLAN's

  • Abans de començar la pràctica es molt convenient explicar els conceptes principals sobre les VLAN's.

Definició de VLAN

  • Una VLAN (acrònim de Virtual LAN, "Xarxa d'Àrea Local Virtual") és un mètode de crear xarxes lògicament independents dins d'una mateixa xarxa física. Diverses VLANs poden coexistir en un únic commutador físic o en una única xarxa física. Són útils per reduir la grandària del domini de difusió i ajuden en l'administració de la xarxa separant segments lògics d'una xarxa d'àrea local.

En que consisteix?

  • Una VLAN consisteix en una xarxa d'ordinadors que es comporten com si estiguessin connectats al mateix commutador, encara que poden estar en realitat connectats físicament a diferents segments d'una xarxa d'àrea local. Els administradors de xarxa configuren les VLANs mitjançant programari en lloc de maquinari, la qual cosa les fa extremadament flexibles.

Definició IEEE 802.Q

  • El protocol IEEE 802.1Q, també conegut com dot1Q, va anar un projecte del grup de treball 802 de la IEEE per desenvolupar un mecanisme que permeti a múltiples xarxes compartir de forma transparent el mateix mig físic, sense problemes d'interferència entre elles (Trunking).

Domini de col·lisió

  • Un domini de col·lisió és un segment físic d'una xarxa de computadors on és possible que els paquets puguin "col·lisionar" (interferir) amb uns altres. Aquestes col·lisions es donen particularment en el protocol de xarxa Ethernet.
Domini colisio 1 baucells.png

Domini de difusió

  • Un domini de difusió és un àrea lògica en una xarxa d'ordinadors en la qual qualsevol ordinador connectat a la xarxa pot transmetre directament a qualsevol un altre en el domini sense precisar cap dispositiu d'encaminament, atès que comparteixen la mateixa subxarxa, adreça de porta d'enllaç i estan en la mateixa VLAN.
Domini difusio 1 baucells.png

Tipus de VLAN's

Tagged

  • Aquesta manera s'utilitza per als ports que es connecten a dispositius que passen tràfic VLAN. Solament posarem un port a "tagged" si aquest va a rebre tràfic de més d'1 VLAN's.
Vlan tagged 1 baucells.png.png
Fitxer Original

Untagged

  • Aquesta manera s'utilitza per als ports que es connecten als nodes finals o altres dispositius que no es passa tràfic VLAN cap a davant. Solament podem tenir 1 VLAN amb "untagged" per port.
Vlan untagged 1 baucells.png


Fitxer original

Trunk port

  • Quan existeix un enllaç entre 2 switches o routers i el switch trasnmite tràfic de més d'una VLAN el port deu configurar-se com "trunk". Un port trunk utilitza el protocol "trunking".
Vlan tagged trunking 1 baucells.png
Fitxer original

Connectar i reiniciar el RouterBoard

  • Un primer problema que podem tenir a l'hora d'iniciar la gestió d'VLAN's es que segurament no estarem dins de la mateixa xarxa que el dispositiu, fent que no puguem accedir a ell. Per a saber quina es la IP del dispositius farem servir la següent comanda "sudo tcpdump -n -i eth0, amb aquesta comanda escoltem la interfici de xarxa "eth0", ja que aquests RoutersBoards, cada cert temps envien paquets amb la seva IP:
sudo tcpdump -n -i eth0
  • Una vegada es pugui fer ping al dispositiu el reiniciarem, amb la finalitat de deixar el RouterBoard amb els paràmetres e fàbrica. Per a realitzar aquesta acció ens connectem al dispositiu via web, obrim una terminal i executem la següent comada:
/system reset-configuration

IMPORTANT: Es important saber que l'opció de reiniciar el RouterBoard per Hardware, per defecte està desactivada!

Restart configuration 1 rpinyol jbaucells.png

Reset per HARDWARE

  • A continuació es mostren dos imatges en cas de no poder fer el reset per SOFTWARE:


Reset hardware 1 rpinyol jbaucells.png


Reset hardware 2 rpinyol jbaucells.png


  • Desprès de reiniciar-lo accedim al RouterBoard (en el nostre cas pel port 2), a continuació descriurem com hem configurats els ports:
    • PORT 1 --> No configurat (firewall).
    • PORT 2 --> No configurat (administració).
    • PORT 3 --> Configurat com a port untagged (always-strip).
    • PORT 4 --> Configurat com a port untagged (always-strip).
    • PORT 5 --> Configurat com a port tagged (add-if-missing) - Port troncal (trunk).

Administració de la CAPA 2

  • El primer que hem fet es assignar el vlan-mode i el vlan-header mode al egress de cada port.
    • S'estableix el mode vlan-mode=secure per assegurar-se que és va un ús estricte de la taula VLAN.
    • S'estableix el mode vlan-header=always-strip als ports d'accés (elimina la capçalera VLAN de la trama Ethernet quan aquesta deixa el chip del commutador)
  • Si fem un print a la configuració dels ports ens apareix el següent:


Routerboard 1 baucells.png


  • Les comandes que hem fet servir son les següents:
/interface ethernet switch port
set 1 vlan-header=always-strip vlan-mode=secure
set 2 vlan-header=always-strip vlan-mode=secure
set 3 vlan-header=add-if-missing vlan-mode=secure


Routerboard 2 baucells.png


  • A continuació afegirem les regles correponents al switch per a que cada paquet sapigui per on té que anar, fem les següents comandes:
/interface ethernet switch rule
add new-dst-ports=ether3-local ports=ether5-local switch=switch1 vlan-header=present vlan-id=300
add new-dst-ports=ether4-local ports=ether5-local switch=switch1 vlan-header=present vlan-id=400


Routerboard 5 baucells.png


  • Tot seguit fem el procés contrari:
/interface ethernet switch rule
add new-dst-ports=ether5-local new-vlan-id=300 ports=ether3-local switch=switch1 vlan-header=not-present
add new-dst-ports=ether5-local new-vlan-id=400 ports=ether4-local switch=switch1 vlan-header=not-present


Routerboard 6 baucells.png


  • Per últim afegirem a la taula VLAN les entrades que permetran marcar els paquets amb un VLAN-ID especific als ports ingress:
/interface ethernet switch vlan
add ports=ether5-local switch=switch1 vlan-id=300
add ports=ether5-local switch=switch1 vlan-id=400
add ports=ether3-local,ether4-local switch=switch1 vlan-id=0


Routerboard 9 baucells.png

Administració de la CAPA 3

  • La configuració més senzilla és la de capa 3. Només cal afegir interfícies virtuals amb les vlans que es volen agregar al port. Suposem que volem configurar el trunking a la interfície ether1 d'un encaminador i fer que formi part de les vlan 1, 2 i 3:
/interface vlan
add name=vlanAlumnat vlan-id=300 interface=ether5-local disabled=no
add name=vlanProfessorat vlan-id=400 interface=ether5-local disabled=no


Routerboard 7 baucells.png


  • Ja esteu fent trunking. Normalment a més voldreu assignar al router una IP de cada vlan:
/ip address 
add address=192.168.5.1/24 interface=vlanAlumnat
add address=192.168.10.1/24 interface=vlanProfessorat


Routerboard 8 baucells.png

Configurar Switch 3Com

  • Per a poder realitzar la pràctica de forma correcta hem de configurar el switch per a accedir pel port 1. A continuació es mostren les comandes per a donar una direció IP estàtica al port 1 del switch:
system-view
interface vlan 1
ip address 192.168.x.y 255.255.255.0
(CTRL+Z)
save
  • Tot seguit es mostren les imatges del procés anterior:


Config sw1 jbaucells.png


Config sw2 jbaucells.png


Config sw3 jbaucells.png


Config sw4 jbaucells.png


Config sw5 jbaucells.png

Creació de VLAN's (CAPA 2)

  • La primera VLAN que hem creat es la de alumnat, tot seguit es mostren els passos realitzats:
  • El primer que farem es anar a l'opció de configuració de les VLAN:
Vlan alumnat 1 rpinyol jbaucells.png


  • Tot seguit crearem un ID per a la VLAN que hem de crear:
Vlan alumnat 2 rpinyol jbaucells.png


  • A continuació seleccinem el port i li assignem la VLAN anteriorment configurada:
Vlan alumnat 3 rpinyol jbaucells.png


  • Per a que sigui un nom mes amigable modifiquem la descripció:
Vlan alumnat 4 rpinyol jbaucells.png


  • Comprovem els canvis realitzats:
Vlan alumnat 5 rpinyol jbaucells.png


  • Podem veure mes detalls a la pestanya que a continuació es mostra:
Vlan alumnat 6 rpinyol jbaucells.png


  • Finalment guardem la configuració:
Vlan alumnat 7 rpinyol jbaucells.png


  • La segona VLAN que hem creat es la de professorat, tot seguit es mostren els passos realitzats:
  • El primer que farem es anar a l'opció de configuració de les VLAN:
Vlan professorat 1 rpinyol jbaucells.png


  • Tot seguit crearem un ID per a la VLAN que hem de crear:
Vlan professorat 2 rpinyol jbaucells.png


  • A continuació seleccinem el port i li assignem la VLAN anteriorment configurada:
Vlan professorat 3 rpinyol jbaucells.png


  • Per a que sigui un nom mes amigable modifiquem la descripció:
Vlan professorat 4 rpinyol jbaucells.png


  • Comprovem els canvis realitzats:
Vlan professorat 5 rpinyol jbaucells.png


  • Podem veure mes detalls a la pestanya que a continuació es mostra:
Vlan professorat 6 rpinyol jbaucells.png


  • Finalment guardem la configuració:
Vlan professorat 7 rpinyol jbaucells.png


Creació de VLAN's (TRUNKING)

  • A continuació configurarem el port que farà de trocal per a les dos VLAN's, tot seguit es mostren els passos:
Trunking 1 jbaucells rpinyol.png
Trunking 21 jbaucells rpinyol.png
Trunking 22 jbaucells rpinyol.png
Trunking 3 jbaucells rpinyol.png
Trunking 4 jbaucells rpinyol.png
Trunking 5 jbaucells rpinyol.png

Actualització del Firmware

  • El microprogramari (en anglès firmware) o programació en firm és un bloc d'instruccions de programa per a propòsits específics, gravat en una memòria ROM, que establix la lògica de més sota nivell que controla els circuits electrònics d'un dispositiu de qualsevol tipus. Al estar integrat en l'electrònica del dispositiu és en part maquinari, però també és programari, ja que proporciona lògica i es disposa en algun tipus de llenguatge de programació.

Funcionament

  • El firmware és l'intermediari (interfície) entre les ordres externes que rep el dispositiu i la seva electrònica, ja que és l'encarregat de controlar a aquesta última per a executar correctament aquestes ordres externes. Trobem el firmware en memòries ROM dels sistemes de diversos dispositius perifèrics, com en monitors de vídeo, unitats de disc, impressores, etc., però també en els propis microprocessadors, xips de memòria principal, en general en qualsevol circuit integrat i també en els reproductors MP3 o MP4. Molts dels firmwares emmagatzemats en ROM estan protegits per drets d'autor.

Instal·lació a RouterBoard 1000 Series

  • A continuació es descriurà com instal·lar un nou Firmware a un RouterBoard de la serie 1000. El primer que hem de fer es anar a aquesta pàgina web i descarrega-nos la versió desitjada. En el nostre cas es la següent:


Firmware rpinyol jbaucells 1 routeros.png


  • Hem de comprovar el MD5 per veure que s'ha baixat correctament, ho farem de la següent manera:


Firmware rpinyol jbaucells 3 routeros.png


  • Ens hem de descarregar el paquet NPK, com es mostra en la imatge anterior i tot seguit mirem la versió del firmware actual:


Firmware rpinyol jbaucells 2 routeros.png


  • A continuació carreguem el fitxer descarregat amb un client FTP, com es mostra a la següent imatge:


Firmware rpinyol jbaucells 4 routeros.png


  • Finalment comprovem que el firmware s'ha modificat:


Firmware rpinyol jbaucells 5 routeros.png

Esquema final

  • A continuació es mostra una imatge de com han quedat els commutadors i tot seguit una explicació de l'esquema:



Vegeu també

Enllaços externs