IMPORTANT: Per accedir als fitxer de subversion: http://acacha.org/svn (sense password). Poc a poc s'aniran migrant els enllaços. Encara però funciona el subversion de la farga però no se sap fins quan... (usuari: prova i la paraula de pas 123456)

Introducció

OSPF(Open Shortest Path First): és un protocol d'enrutament jeràrquic de passarel interior, de envestidura dinàmica IGP (Interior Gateway Protocol), que utilitza l'algorisme SmothWall Dijkstra enlace-estado o link-state (LSA - Link State Algorithm) per a calcular la ruta més curta possible. Utilitzant la mètrica de menor cost. OSPF és probablement el tipus de protocol IGP més utilitzat en xarxes grans.

OSPF pot operar amb seguretat utilitzant MD5 per realitzar connexions segures entre encaminadors veïns.

Al contrari que RIP o BGP, OSPF no utilitza ni TCP ni UDP, sinó que utilitza directament el protocol IP (IP 89) i multicast.

OSPF és el successor natural de RIP i suporta VLSM a més de CIDR.

Exercici amb dispositius RouterOS amb OSPF

Enunciat de lexercici: MP16._Xarxes_WAN_obertes_sense_fils_._201213_Extraordinària_UF2#Enunciat

  • Esquema del model a fer:

Faustomendoza1 EsquemaXarxaOSPF.png

  • El càlcul de les IP's les podem comprovar amb la comanda ipcalc de la següent forma:
  • Per veure les dades de la ip 172.16.7.1/29' que és la ip wan de classe B del Router1 farem el següent:
[email protected] ~ $ ipcalc 172.16.7.1/29
Address:   172.16.7.1           10101100.00010000.00000111.00000 001
Netmask:   255.255.255.248 = 29 11111111.11111111.11111111.11111 000
Wildcard:  0.0.0.7              00000000.00000000.00000000.00000 111
=>
Network:   172.16.7.0/29        10101100.00010000.00000111.00000 000
HostMin:   172.16.7.1           10101100.00010000.00000111.00000 001
HostMax:   172.16.7.6           10101100.00010000.00000111.00000 110
Broadcast: 172.16.7.7           10101100.00010000.00000111.00000 111
Hosts/Net: 6                     Class B, Private Internet
  • El mateix farem per veure les dades de la ip 192.168.70.1/24' que en aquest cas és la IP LAN del Router1:
[email protected] ~ $ ipcalc 192.168.70.1/24
Address:   192.168.70.1         11000000.10101000.01000110. 00000001
Netmask:   255.255.255.0 = 24   11111111.11111111.11111111. 00000000
Wildcard:  0.0.0.255            00000000.00000000.00000000. 11111111
=>
Network:   192.168.70.0/24      11000000.10101000.01000110. 00000000
HostMin:   192.168.70.1         11000000.10101000.01000110. 00000001
HostMax:   192.168.70.254       11000000.10101000.01000110. 11111110
Broadcast: 192.168.70.255       11000000.10101000.01000110. 11111111
Hosts/Net: 254                   Class C, Private Internet

Ús del ipaliasing

  • Abans d'accedir a un dispositius RouterOS hem de configurar la nostra màquina per tenir la mateixa ip que la que ve al dispositiu per defecte, en aquest cas hem de colocar una de la xarxa 192.168.88.0/24 ja que la ip del router és la 192.168.88.1, llavors per no desconfigurar la nostra configuració de xarxa farem un ipaliasing utilitzant la comanda ifconfig.
  • En aquest cas tenim la configuració de xarxa següent:
[email protected] ~ $ ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:08:ca:9d:a9:c0  
          inet addr:192.168.202.189  Bcast:192.168.202.255  Mask:255.255.255.0
          inet6 addr: fe80::208:caff:fe9d:a9c0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:244854 errors:0 dropped:0 overruns:0 frame:0
          TX packets:81994 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:46755584 (46.7 MB)  TX bytes:11947969 (11.9 MB)

[email protected] ~ $
  • Llavors per tenir una adreça ip de la mateixa xarxa del dispositiu RouterOS utilitzarem la següent comanda:
[email protected] ~ $ sudo ifconfig wlan0:mikrotik 192.168.88.40/24

A on la paraula mikrotik podem utilitzar la que sigue ja que és per a diferenciar amb el nom de la interficie que estem utilitzant.

Configuració Router1

  • Escriurem el nom corresponent a cada interficie de xarxa per deixar-les com les de l'esquema.

Faustomendoza1Router1Interfaces.png

  • Anirem a IP --> Address per afegire les interficies

Fautomendoza1Router1IPAddress.png

  • Afegirem les adreces corresponents a cada interficie.

Fautomendoza1Router1IPAddressAsignat.png

  • El resultat amb les interficies configurades serà el següent

Fautomendoza1Router1IPAddressConfigurat.png

Configuració del Protocol OSPF del Router1

A continuació anirem a Routing --> OSPF

Faustomendoza1MikOSPF.png

En la finestra que ens sortirà anirem a la pestanya Instances i configurarem la instancia per defecte(default)

Faustomendoza1MikOSPF instancia.png

A la finestra que ens sortirà omplirem els camps corresponents d'aquest router com el nom i la IP que serà el ID.

Faustomendoza1MikOSPFConf.png

Ara anirem a la pestanya Networks per afegir les xarxes les quals volem compartir de forma dinàmica amb OSPF.

Faustomendoza1MikOSPF Networks.png

NOTA: Podem veure que en aquest s'ha d'afegir la xarxa indicant la màscara amb una / seguit del numero i a més a més incluint el backbone per defecte

El resultat serà el següent:

Faustomendoza1MikOSPF Networks result.png

Podem comprovar que a la pestanya Interfaces s'han afegit de forma dinàmica les interficies que es troben a les xarxes que acabem d'escriure a la pestanya Networks.

Faustomendoza1MikOSPF Interfaces result.png

Afegir filtres

Anirem a Routing --> Filters i afegirem els següents filtres:

Faustomendoza1FiltresR1.png

A la pestanya Actions farem seleccionarem que el rebutlli.

Faustomendoza1Filtres2R1.png

El resultat dels filtrs serà el següent:

Faustomendoza1Filtres2R1result.png

Configuració Router2

  • Escriurem el nom corresponent a cada interficie de xarxa per deixar-les com les de l'esquema.

Faustomendoza1Router2Interfaces.png

  • Anirem a IP --> Address per afegire les interficies

Fautomendoza1Router2IPAddress.png

  • Afegirem les adreces corresponents a cada interficie.

Fautomendoza1Router2IPAddressAsignat.png

  • El resultat amb les interficies configurades serà el següent

Fautomendoza1Router2IPAddressConfigurat.png

Configuració del Protocol OSPF del Router2

Seguint els mateixos passos del Router1 a continuació anirem a Routing --> OSPF

Faustomendoza1MikOSPF.png

En la finestra que ens sortirà anirem a la pestanya Instances i configurarem la instancia per defecte(default)

Faustomendoza1MikOSPF instancia.png

A la finestra que ens sortirà omplirem els camps corresponents d'aquest router com el nom i la IP que serà el ID.

Faustomendoza1Mik2OSPFConf.png

Quedant com a resultat:

Faustomendoza1Mik2OSPFConfinstancia.png

Ara anirem a la pestanya Networks per afegir les xarxes les quals volem compartir de forma dinàmica amb OSPF.

Faustomendoza1Mik2OSPF Networks.png

NOTA: Podem veure que en aquest s'ha d'afegir la xarxa indicant la màscara amb una / seguit del numero i a més a més incluint el backbone per defecte

El resultat serà el següent:

Faustomendoza1Mik2OSPF Networks result.png

Podem comprovar que a la pestanya Interfaces s'han afegit de forma dinàmica les interficies que es troben a les xarxes que acabem d'escriure a la pestanya Networks.

Faustomendoza1Mik2OSPF Interfaces result.png

Afegir filtres

Anirem a Routing --> Filters i afegirem els següents filtres:

Faustomendoza1FiltresR2.png

A la pestanya Actions farem seleccionarem que el rebutlli.

Faustomendoza1Filtres2R2.png

El resultat dels filtres serà el següent:

Faustomendoza1Filtres2R2result.png

Comprovacions

Intercanvi de rutes amb el protocol OSPF

Una vegada tenim configurat el protocol OSPF podem anar a la pestanya Routes per comprovar que el intercanvi de rutes s'hagi fet.

Router1

Faustomendoza1RoutesOSPF R1.png

  • En el cas anterior podem veure que en aquest router només ha hagut intercanvi dela ruta de la xarxa interna de l'altre router, també ens podem fixar que indica el cost que és la mètrica que utilitza per determinar la distància que es troba el router d'aquella xarxa.


Router2
  • Podem veure que passa el mateix a l'altre router.

Faustomendoza1RoutesOSPF comprovacio1.png

Identificar els veïns de cada router

Router1:

Podem veure a la pestanya Neighbors els veïns que té cada router amb el seu ID i la interficie per on ho troba:

Faustomendoza1Router1Vei.png

Router2:

Podem veure que al router passa el mateix:

Faustomendoza1Router2Vei.png

Comprovació amb els clients

A la part de la xarxa lan del router1 configurarem la xarxa d'un pc client en aquest cas utilitzarem un en sistema operatiu windows. La Configuració de la xarxa serà la següent: Faustomendoza1ConfXarxaClientR1.png

Amb la configuració anterior farem un ping d'un extrem de la xarxa a un altre.

Faustomendoza1ConfXarxaClientR1Ping.png

Podem veure que el ping el respon amb èxit.

Faustomendoza1ConfXarxaClientR1PingResult.png

I amb la comanda tracert(de windows) podem veure els salts que fa el paquet.

Faustomendoza1ConfXarxaClientR1TracertResult.png

A l'extrem de la xarxa des de la màquina client en linux podem veure que el resultat és el mateix.

Faustomendoza1ConfXarxaClientR2.png

Ping

Faustomendoza1ConfXarxaClientR1PingResul2t.png

I també amb la comanda traceroute en linux podem comprovar els salts que fa un paquet.

Faustomendoza1ConfXarxaClientR1TracerouteResult.png

Backups

Per fer backups al sistemes RouterOS haurem d'utilitzar la comanda export amb el paràmetre compact quedant de la següent forma:

Faustomendoza1ExportCompactRouterOS.png

Descàrrega de l'arxiu:

  • Backup del Router1
# jun/09/2013 04:17:55 by RouterOS 6.0
# software id = EHLB-AI69
#
/interface ethernet
set 1 name=ether2-lan
set 2 disabled=yes
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m \
    mac-cookie-timeout=3d
/routing ospf instance
set [ find default=yes ] distribute-default=always-as-type-2 name=Fausto-R1 \
    redistribute-connected=as-type-2 redistribute-other-ospf=as-type-2 \
    redistribute-static=as-type-2 router-id=172.16.7.1
/tool user-manager customer
add backup-allowed=yes disabled=no login=admin password="" \
    paypal-accept-pending=no paypal-allowed=no paypal-secure-response=no \
    permissions=owner signup-allowed=no time-zone=-00:00
/ip address
add address=172.16.7.1/29 interface=ether1 network=172.16.7.0
add address=192.168.70.1/24 interface=ether2-lan network=192.168.70.0
/routing filter
add action=reject chain=ospf-in comment="Rebutjar entrada de rutes classe A" \
    prefix=10.0.0.0/8
add action=reject chain=ospf-out comment="Rebutjar sortida de rutes classe A" \
    prefix=10.0.0.0/8
/routing ospf network
add area=backbone network=172.16.7.0/29
add area=backbone network=192.168.70.0/24
/system identity
set name=Fausto-R1
/system lcd
set contrast=0 enabled=no port=parallel type=24x4
/system lcd page
set time disabled=yes display-time=5s
set resources disabled=yes display-time=5s
set uptime disabled=yes display-time=5s
set packets disabled=yes display-time=5s
set bits disabled=yes display-time=5s
set version disabled=yes display-time=5s
set identity disabled=yes display-time=5s
set ether1 disabled=yes display-time=5s
set ether2-lan disabled=yes display-time=5s
set ether3 disabled=yes display-time=5s 


Fitxer:CopisaSegRouter1Fausto.rsc

  • Backup del Router2
# jun/19/2013 16:56:06 by RouterOS 6.0
# software id = QPQ3-FHIK
#
/interface ethernet
set 1 name=ether2-lan
set 2 disabled=yes
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m \
    mac-cookie-timeout=3d
/routing ospf instance
set [ find default=yes ] distribute-default=always-as-type-2 name=Fausto-R2 \
    redistribute-connected=as-type-2 redistribute-other-ospf=as-type-2 \
    redistribute-static=as-type-2 router-id=172.16.7.2
/tool user-manager customer
add backup-allowed=yes disabled=no login=admin password="" \
    paypal-accept-pending=no paypal-allowed=no paypal-secure-response=no \
    permissions=owner signup-allowed=no time-zone=-00:00
/ip address
add address=172.16.7.2/29 interface=ether1 network=172.16.7.0
add address=192.168.80.1/24 interface=ether2-lan network=192.168.80.0
/routing filter
add action=reject chain=ospf-out comment="Rebutjar sortida de Rutes Clase A" \
    prefix=10.0.0.0/8
add action=reject chain=ospf-in comment=\
    "Rebutjar la entrada de rutes clase A" prefix=10.0.0.0/8
/routing ospf network
add area=backbone network=172.16.7.0/29
add area=backbone network=192.168.80.0/24
/system identity
set name=Fausto-R2
/system lcd
set contrast=0 enabled=no port=parallel type=24x4
/system lcd page
set time disabled=yes display-time=5s
set resources disabled=yes display-time=5s
set uptime disabled=yes display-time=5s
set packets disabled=yes display-time=5s
set bits disabled=yes display-time=5s
set version disabled=yes display-time=5s
set identity disabled=yes display-time=5s
set ether1 disabled=yes display-time=5s
set ether2-lan disabled=yes display-time=5s
set ether3 disabled=yes display-time=5s 


Fitxer:CopisaSegRouter2Fausto.rsc


NOTA: El contingut d'aquests arxius són les comandes per configurar el router, les quals les podem utilitzar directament pel terminal d'aquest dispositius.

Vegeu També

Enllaços externs