IMPORTANT: Per accedir als fitxer de subversion: http://acacha.org/svn (sense password). Poc a poc s'aniran migrant els enllaços. Encara però funciona el subversion de la farga però no se sap fins quan... (usuari: prova i la paraula de pas 123456)

EOIP

Ethernet over IP (EoIP) Tunneling és un protocol de MikroTik RouterOS que permet crear un túnel ethernet entre dos routers de diferents xarxes.

El túnel EoIP hauria de funcionar sobre una connexió capaç de transportar dades i paquets IP. Quan el router actua com a pont, tot el tràfic ethernet (tots els protocols ethernet) funcionaran com si hi hagués una cable directe entre un router i l'altre. Aquest protocol fa diversos esquemes possibles de xarxa.

  • Configuracions de xarxa amb interfície EoIP:
Fer un pont LAN a través d'internet
Fer un pont LAN a través de túnels encriptats
Fer un pont LAN a través de xarxes WLAN 'ad-hoc'
  • El protocol EoIP encapsula trames ethernet amb paquets GRE (igual que ho fa PPTP) i els envia a la punta remota del túnel EoIP.

Propietats

Propietat Opcions Descripció Per defecte
arp enabled | proxy-arp | reply-only Protocol de resolució d'adreces enable
keepalive integer Estableix l'interval de temps (en segons) en que es recibeixen missatges keep-alive. Si es perden 3 missatges s'eliminarà la interfície activa. Per a que funcioni correctament, el valor del temps ha de ser igual a les dues bandes del túnel not set
12mtu integer Unitat de transmissió màxima de la capa 2. No és configurable per EoIP not set
mac-address Adreça MAC L'adreça MAC. Es poden utilitzar lliurement els rangs des de 00:00:5E:80:00:00 fins 00:00:5E:FF:FF:FF -
mtu integer Unitat de transmissió màxima de capa 3 1500
name string El nom de la interfície -
remote-address Adreça IP L'adreça IP de la banda final del túnel EoIP -
tunnel-id integer:65536 Identficador únic del túnel. Ha de concordar a les dues bandes -
  • Notes:
  • La propietat tunnel-id és un mètode d'identificació del túnel.
  • mtu hauria d'estar sempre a valor 1500 per eliminar la desfragmentació de paquets dins el túnel (això permet una connexió pont transparent i seria possible transportar trames ethernet completes per tot el túnel).
  • És altament recomanat utilitzar adreces MAC úniques per a cada túnel.
  • Per a les interfícies EoIP es pot utilitzar lliurement el següent rang d'adreces: des de 00:00:5E:80:00:00 fins 00:00:5E:FF:FF:FF. No obstant, es pot programar el segon bit del primer byte per a marcar l'adreça com una adreça administrada localment, assignada per l'administrador de la xarxa, i utilitzar qualsevol adreça MAC. Tant sols t'has d'assegurar que és única entre els hosts que formen el túnel.

IMPORTANT: El túnel EoIP afegeix com a mínim 42 Bytes de més (8 Bytes GRE + 14 Bytes de ethernet + 20 Bytes IP)


TODO: Aconseguir exemple/gràfica trama EOIP 

TODO:

Configuració

Volem montar un pont transparent a traves internet. EL túnet PPtp tant sols és necessari per afegir encriptació, ja que EoIP no ho ofereix.

Hi ha diverses parts durant la configuració les quals explicarem individualment després. Primer em de distingir la IP pública del router per una banda i la IP privada del router per l'altra.

NOTA: la IP privada és del mateix rang als dos routers

Per començar la configuració el primer que farem serà fer el túnel PPtP. El primer router farà de servidor

Router 1 (Router Server)

Mode gràfic

Primer de tot modificarem les interfícies de de manera de que quedi així.

Interfícies


Configurarem els ports "eth" del routerboard per tal de fer la xarxa

  • eth2
    • address: 192.168.88.1/24
    • network: 192.168.88.0
  • eth3
    • address: 192.168.81.1/24
    • network: 192.168.81.0

NOTA: Al final del procés es creara automàticament la interfície:

  • pptp-in1
    • address: 172.0.0.10
    • network: 172.0.0.12
Address list.png

Tunel PPTP


Ara crearem el tunel PPTP per tal de que la connexió tingui més seguretat.

Primer ficarem en funcionament amb l'opció "Enable"

On pptp.png

En la pestanya "Secrets" afegirem una configuració de seguretat per tal de que només el client pugui accedir, primer assignarem un usuari i contrasenya i després assignem qui amb "remote address"

  • Name: danny
  • Password: danny
  • Service: pptp
  • Local Address: 172.0.0.10
  • Remote Address: 172.0.0.12

Pptp tuneling1.png    Pptp tuneling2.png

CONNECTAT!!
Pptp connectat dlrh.png

Tunel EoIP


Una vegada ficada la seguretat fiquem el tunel EoIP per crear una sola xarxa inclús Internet pel mig. Ho farem anant a Interfices, a la pestanya EoIP i afegirem un nou tunel amb les següents característiques.

Interficie EoIP

  • Name: eoip-tunnel-serv
  • Local Address: 192.168.81.1
  • Remote Address: 192.168.81.2
  • Tunnel ID: 110
Eoip tuneling.png

Bridge


Afegirem un bridge des de "Bridge" de nom bridge.

Newbridge dlrh.png

Un cop creat el bridge1 li afegirem 2 ports per a que es connectin entre els routers. Ho farem anant a la pestanya "Ports"

Pont 1

interface: eth2

bridge: bridge1

Bridge port1 dlrh.png

Pont 2

interface: eoiptunnel

bridge: bridge1

Bridge port2 dlrh.png


Resultat de Interfaces


Resultat final dlrh.png

Ho comprovem fent un ping

Ping server-client eoip dlrh.png

Router 2 (Router Client)

  • Aquest router fa la funció de router client.
  • Anem a configurar pas a pas el necessari per a que es connecti amb el router servidor i es pugui realitzar el túnel pptp i el túnel eoip.

Configuració Inicial

Configurem una IP i una adreça de xarxa al port 2 del router. Ho fem de la següent manera:

  • Quina interface tenim?
ifconfig
Usuari-Gerardsese Practica EoIP Interface.png
  • Configurem les IPs per al port número 2 del router:
sudo ifconfig eth0 192.168.88.5
sudo route add default gw 192.168.88.1
Usuari-Gerardsese Practica EoIP Configurar IPs.png


Usuari-Gerardsese Practica EoIP Configurar IPs 02.png


Usuari-Gerardsese Practica EoIP Configurar IPs 03.png

Winbox

NOTA: L'aplicació Winbox és per a plataformes Windows. Per a que funcioni amb Linux ho aconseguim descarregant-nos el paquet wine

  • Aquesta és la interface del programa winbox:
Usuari-Gerardsese Practica EoIP Interface Wibox.png

Primer Pas

  • Mètode amb línia de comandes:
/interface pptp-client 
add name="pptp-tunnel" connect-to=192.168.81.1 \
user="USERNAME" password="PASS" \
profile=default-encryption add-default-route=no \
disabled=no 
  • Mètode Gràfic:

1.-Anem a Interfaces. L'aspecte inicial és el següent:

Usuari-Gerardsese Practica EoIP Interfaces Inicial.png

2.-Fem clic al botó '+' i elegim PPTP Client:

Usuari-Gerardsese Practica EoIP Interfaces Boto +.png

3.-Configurem la interfície PPTP Client de la següent manera:

3.1- A la pestanya General --> Name: pptp-client
3.2- A la pestanya Dial Out:
3.2.1.- Connect to: 192.168.81.1 (Indiquem que el túnel PPTP funcionarà pel port amb IP 192.168.81.1).
3.2.2.- Nom d'usuari i paraula de pas (configurats al router servidor).
Usuari-Gerardsese Practica EoIP Interfaces PPTP CLient.png


Usuari-Gerardsese Practica EoIP Interface PPTP Client Configurat.png

Segon Pas

  • Mètode amb línia de comandes:
/interface eoip add name=eoiptunnel remote-address=192.168.88.1 \
tunnel-id=110 disabled=no
  • Mètode gràfic:

1.-Creem el túnel EoIP.

1.1.-Anem a Interfaces i fem clic al símbol '+'. De la llista desplegable seleccionem EoIP tunnel:
Usuari-Gerardsese Practica EoIP Interfaces Simbol + EoIP.png

2.-A la pestanya General, modifiquem les següents opcions:

2.1.-Name: eoiptunnel
2.2.-Remote Address: 192.168.81.1 (Adreça del port 3 del router)
2.3.-Tunnel ID: 110(Número que hagi decidit el router server)
Usuari-Gerardsese Practica EoIP Interface EoIP Config.png


Usuari-Gerardsese Practica EoIP Interfaces Despres EoIP.png

Tercer Pas

  • Mètode amb línia de comandes:
/interface bridge add name=bridge1
  • Mètode gràfic:

1.-A Interfaces. Fem clic al botó '+' i seleccionem Bridge:

Usuari-Gerardsese Practica EoIP Interfaces Simbol + Bridge.png

2.- A la pestanya General tant sols tenim que escriure el nom bridge1 a Name:

Usuari-Gerardsese Practica EoIP Interface bridge1 Config.png


Usuari-Gerardsese Practica EoIP Interfaces Despres Bridge1.png

Últim Pas

  • Mètode amb línia de comandes:
/interface bridge port add bridge=bridge1 interface=ether3
/interface bridge port add bridge=bridge1 interface=eoiptunnel
  • Mètode gràfic:

1.-Anem a Bridge. 2.-Anem a la pestanya Ports:

Usuari-Gerardsese Practica EoIP Bridge Ports.png

3.-Aquí tenimq ue crear 2 ports: el port que fa de pont i el port EoIP.

3.1.- Creem primer el port eoiptunnel:
3.1.2.- Ho configurem de la següent manera:
  • Interface:eoiptunnel
  • Bridge: bridge1
Usuari-Gerardsese Practica EoIP Bridge Ports eoiptunnel.png
3.2.- Ara creem el pont al port ether3:
3.2.1.- Interface: ether3
3.2.2.- Bridge: bridge1
Usuari-Gerardsese Practica EoIP Bridge Ports Configurat.png

Comprovacions

  • Anem a Interfaces i fem clic al port pptp-client. Observem que a la part de baix fica Status: Connected. Això ens indica que el túnel pptp funciona correctament:
Usuari-Gerardsese Practica EoIP Comprovacions 1.png
  • Anem a Tools --> Ping i fem ping a la direcció IP 192.168.81.1. Aquesta direcció és la del port 3 per la qual fem els túnels:
Usuari-Gerardsese Practica EoIP Comprovacions 2 Ping.png


Usuari-Gerardsese Practica EoIP Comprovacions 2.png

Errors

  • No confundir les adreces remotes amb les adreces que sen's assignen per defecte (prèvia configuració del router servidor) automàticament un cop fet el túnel EoIP.
  • Si no podem accedir al router a través del winbox pot ser perquè no s'ha configurat bé la IP de la màquina i la porta d'enllaç. Si encara així el problema persisteix, el millor es reiniciar el router i connectar-nos via web amb l'adreça 192.168.88.1


Fitxers

Explicació gràficament

Gràfica original: Fitxer:Graf conf dlrh.doc

Bridge EoIP dlrh.png
Bridge EoIP dlrh1.png

Backup's dels routers

Enllaços