IMPORTANT: Per accedir als fitxer de subversion: http://acacha.org/svn (sense password). Poc a poc s'aniran migrant els enllaços. Encara però funciona el subversion de la farga però no se sap fins quan... (usuari: prova i la paraula de pas 123456)

http://blackhold.nusepas.com/2011/04/nodos-hibridos-guifi-net/

Utilitzar NAT

  • Les radios (nanos, rockets M5, etc) continuen funcionant en mode bridge
  • Es continuen necessitant 4 IP de tipus B (172.x.x.x) una per a cada dispositiu en un enllaç punt a punt amb WDS (2 radios ubiquity 2 dispositius RB)
  • El que no cal és posar un IP aliasing a aquests trastos.
  • Tots els dispositius (nanos, RB, rockets) han de tenir una IP pública de guifi, el que fem és però que sigui la RB750G la que tingui les durs IP, però una la reenviem per DNAT (a l'estil del que alguns dispositius diuen DMZ) una de les IP al la nano/rocket. La norma farà quelcom similar a reenviar els paquets rebuts a una Ip 10.x.x.x a la Ip 172.18.x.x de la radio:
10.x.x.x --> 172.18.x.x

Per què no vam detectar l'error a Terres de l'Ebre?

  • La configuració dels AP (sectorials) és igual.
  • El problema és amb el bridge dels punt a punt, es fa difonent el rang de broadcast pels enllaços. No ho hem detectat per què no tenim dos enllaços seguits...
  • No posar com a switch els ports que tenen connectades radio per a punts a punt amb WDS.

Esquema

L'esquema i els dispositius utilitzats per aquest model són:

EsquemaModelHibrid.png

NOTA: Al dibuix hi ha un error: el trasto TortosaAlcanyiz_T2 té la IP 172.16.135.20 i no la 17 que apareix

Configuració

Dels trastos

Nanostations

Les nanostation estan definides en mode bridge i amb un enllaç WDS. Cal destacar a més que al estar en mode brige la forma en que se'ls hi ha assignat dos adreces IP és posant un IP Aliasing.

Bàsicament el que s'ha fet per configurar-les a mà:

NanostationModelHíbridGuifi0.png
  • Anar a la pestanya wireless i posar l'enllaç en WDS:

NOTA: Les següents captures de pantalla corresponen a la nanostation que va d'estació WDS (Trasto TortosaAlcanyiz26_T1). Al final poso també les captures de pantalla de la nanostation que fa de WDS Access Point

NanostationModelHíbridGuifi1.png
  • Anar a la pestanya network i posar
NanostationModelHíbridGuifi2.png

No hi cap configuració especial ni a Firewall ni a Static Routes però a IP Aliasing hem posat:

NanostationModelHíbridGuifi3.png
  • A la pestanya Advanced no s'ha tocar res:
NanostationModelHíbridGuifi10.png

IMPORTANT: Oco amb el DFS!!! A la foto surt activat i segurament voldreu desactivar-lo sinó va canviant de freqüències i provoca microtalls.

  • A Services trobareu:
NanostationModelHíbridGuifi4.png

HI ha System s'ha posat el nom que correspon al trasto/s segons el indicat a guifi.net i s'ha canviat la paraula de pas per defecte i activat l'usuari guest (password guest):

NanostationModelHíbridGuifi5.png

Captures de pantalla de l'altre nanostation (Access Point WDS):

NanostationModelHíbridGuifi11.png
NanostationModelHíbridGuifi12.png
NanostationModelHíbridGuifi13.png
NanostationModelHíbridGuifi14.png
NanostationModelHíbridGuifi15.png
NanostationModelHíbridGuifi16.png

RB 750G

IMPORTANT: Cal fer srcnat de les IP de gestió de l'encaminament, és a dir les 172.16.0.0/12

Per configurar aquest trasto s'ha agafat el unsolclic d'un trasto en funcionament com per exemple:

http://guifi.net/guifi/device/19633/view/unsolclic

I s'ha anat posant les configuracions a través de winbox a mà. La llista del que cal fer la trobareu a:

RB_750G#Configuraci.C3.B3_manual

Cal tenir en compte que les passes inicial el que fan es treure la configuració per defecte del dispositiu RB 750G (éstà configurat com el típic router SoHo)

Un cop seguides les passes indicades s'ha procedit a intentar configurar l'Encaminament dinàmic amb OSPF seguint les passes de:

RouterOS#OSPF_a_guifi.net

Però s'han tingut problemes. Consulteu Model_híbrid_guifi.net#Les_routes_s.27intercanvien_b.C3.A9_per_OSPF_per.C3.B2_no_queden_actives

La següent captura de pantalla intenta mostrar els resultats d'aquest configuració:

RB750GMOdelHibrid.png

De guifi.net

Els nodes en qüestió són:

Resol·lució de problemes

Les routes s'intercanvien bé per OSPF però no queden actives

IMPORTANT: La sol·lució la he trobat als filtres de routing de la microtik: Routing > Filters, els he desactivat i ja funcionen les rutes dinàmiques. Si ho torno a activar aleshores funcionen les de classe A i no pas les de classe B

RoutingFilters.png

Si us fixeu seguint la configuració de l'enrutament dinàmic amb OSPF d'aquest article, les rutes apareixen però no estan actives(en blau):

RB750GModelHibridGuifinetOSPF.png

Si consulteu http://guifi.net/tortosa veureu com apareixen totes les rutes de "l'illa" de Tortosa. El problema però és que no estan actives i no són reacheable.

En una configuració amb OSPF que si que funciona (enllaç entre els nodes INSEbre i Roser de Tortosa) podem veure el següent:

El que té més tela és el següent. A Tortosa tenim els següents routers amb OSPF activat:

TortosaRoser <--- WDS ---> TortosaInsEbre(Microtik RB600) <--- Enllaç cable ---> TortosaInsEbre(RB 750G) <-- WDS mitjançant nanos --> TortosaAlcanyiz26 (RB 750G)

La següent taula de rutes és de TortosaInsEbre(RB 750G)

RB750GModelHibridGuifinetOSPF0.png

En canvi a TortosaInsEbre(Microtik RB600) tenim:

RB750GModelHibridGuifinetOSPF1.png

Fixeu-vos que la ruta de les IP de classe A:

10.36.253.168/29 està Ok/reacheable 

(puc fer pings a les màquines d'aquesta ruta) però no la ruta:

172.16.135.16/29 

Lo més curiós de tot és que si de les rutes "detectades/intercanviades" correctament en fem una copia i les posem com estàtiques tot funciona correctament (però esta configuració no és gaire dinàmica ;-))

Anoto per que quedi referència alguns dels suggeriments fets a les llistes:

  • Tenir la última versió de airOS: fet:
Firmware Version: 	XM.v5.2.1
Build Number: 	6359

Sebastian Galeano:

Si et fitxes amb el torch, mira si a la rb surten els OSPF-hellos cada 10segons cap a broadcast, despres mira a l'altre si arriben, hi ha un tema amb versions del AirOS V i 
depen del mode de funcionament es filtra el broadcast/multicast.

Torch a la RB 750G 10.36.523.11 (Node Institut de l'Ebre)

OSPFDebug.png

Torch a la RB 750G 10.36.523.70 (Node Alcanyiz26)

OSPFDebug1.png
OSPFDebug01.png

Més aportacions de la gent:

  • Provar amb l'enllaç WDS en ap-wds<->ap-wds. També es pot provar de posar en auto els wdspeers.
  • Prova a que el ospf es comunique via unicast (nbma) en lloc de brodadcast .

Segons tinc entès, els routers d'una mateixa area intercanvien les LSA's, quan tots els routers d'una mateixa area tenen les mateixes LSA's es creen les rutes dinàmiques. Si dos routers no formen part de la mateixa area o les LSA's no son les mateixes en tots dos, potser que les vegin però no esdevinguin rutes actives.

Per tant crec que la clau podria estar en el tema de les arees, comprovar que totes estiguen definides com a backbone en totes les interfaces i xarxes. També comprovar que tots dos routers tinguen els mateixos LSA's a les taules, es possible que rebin els LSA's i per això apareixen les rutes, però si no coincideixen les LSA's als dos routers, les rutes no s'activen.

Nosotros tenemos varios nodos funcionando así. Alguno nos está dando problemas con el OSPF. No sabemos por qué ya que hay momentos en los que funciona. Pensamos que es 
porque hay diferentes versiones en routeros, openwrt y airos, pero no estamos seguros. La mayoría funcionan perfectamente.

En las antenas ubiquiti tienes modo bridge y una 172. Nosotros ponemos una pública 10.  para poder entrar a configurarla por web sin hacer nada más. La 172 la tiene el 
mikrotik.
En el enrutamiento tienes redes broadcast. Nosotros no ponemos que sean de difusión y nombramos los vecinos NBMA. Eso recomendaban en los  manuales de routeros.
De todas formas, revisa el unsolclic. La configuración que ofrece intercambia las 172 pero no las pone activas. Parece que estés haciendo lo mismo.

La configuració en aquest moment (--acacha 05:45, 23 nov 2010 (UTC)) és:

# jan/09/1970 16:52:28 by RouterOS 4.10
# software id = PBAS-D69F
# 
/interface ethernet
set 0 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment=\
    "" disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:5F:B7:0A \
    master-port=none mtu=1500 name=ether1 speed=100Mbps
set 1 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment=\
    "" disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:5F:B7:0B \
    master-port=ether1 mtu=1500 name=ether2 speed=100Mbps
set 2 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment=\
    "" disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:5F:B7:0C \
    master-port=ether1 mtu=1500 name=ether3 speed=100Mbps
set 3 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment=\
    "" disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:5F:B7:0D \
    master-port=ether1 mtu=1500 name=ether4 speed=100Mbps
set 4 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment=\
    "" disabled=no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:5F:B7:0E \
    master-port=none mtu=1500 name=ether5 speed=100Mbps
/interface ethernet switch
set switch1 mirror-source=none mirror-target=none name=switch1
/ip hotspot profile
set default dns-name="" hotspot-address=0.0.0.0 html-directory=hotspot \
    http-cookie-lifetime=3d http-proxy=0.0.0.0:0 login-by=cookie,http-chap \
    name=default rate-limit="" smtp-server=0.0.0.0 split-user-domain=no \
    use-radius=no
/ip hotspot user profile
set default idle-timeout=none keepalive-timeout=2m name=default shared-users=\
    1 status-autorefresh=1m transparent-proxy=no
/ip ipsec proposal
set default auth-algorithms=sha1 comment="" disabled=no enc-algorithms=3des \
    lifetime=30m name=default pfs-group=modp1024
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ppp profile
set default change-tcp-mss=yes comment="" name=default only-one=default \
    use-compression=default use-encryption=default use-vj-compression=default
set default-encryption change-tcp-mss=yes comment="" name=default-encryption \
    only-one=default use-compression=default use-encryption=yes \
    use-vj-compression=default
/queue type
set default kind=pfifo name=default pfifo-limit=50
set ethernet-default kind=pfifo name=ethernet-default pfifo-limit=50
set wireless-default kind=sfq name=wireless-default sfq-allot=1514 \
    sfq-perturb=5
set synchronous-default kind=red name=synchronous-default red-avg-packet=1000 \
    red-burst=20 red-limit=60 red-max-threshold=50 red-min-threshold=10
set hotspot-default kind=sfq name=hotspot-default sfq-allot=1514 sfq-perturb=\
    5
set default-small kind=pfifo name=default-small pfifo-limit=10
/routing bgp instance
set default as=65530 client-to-client-reflection=yes comment="" disabled=no \
    ignore-as-path-len=no name=default out-filter=ospf-out \
    redistribute-connected=yes redistribute-ospf=yes redistribute-other-bgp=\
    yes redistribute-rip=yes redistribute-static=yes router-id=10.36.253.170 \
    routing-table=""
/routing ospf instance
set default comment="" disabled=no distribute-default=never in-filter=ospf-in \
    metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=\
    auto metric-rip=20 metric-static=20 name=default out-filter=ospf-out \
    redistribute-bgp=as-type-1 redistribute-connected=no \
    redistribute-other-ospf=no redistribute-rip=no redistribute-static=no \
    router-id=10.36.253.170
/routing ospf area
set backbone area-id=0.0.0.0 comment="" disabled=no instance=default name=\
    backbone type=default
/snmp
set contact=guifi@guifi.net enabled=yes engine-boots=0 engine-id="" location=\
    TortosaAlcanyiz26_T2 time-window=15 trap-sink=0.0.0.0 trap-version=1
/snmp community
set public address=0.0.0.0/0 authentication-password="" \
    authentication-protocol=MD5 encryption-password="" encryption-protocol=\
    DES name=public read-access=yes security=none write-access=no
/system logging action
set memory memory-lines=100 memory-stop-on-full=no name=memory target=memory
set disk disk-file-count=2 disk-file-name=log disk-lines-per-file=100 \
    disk-stop-on-full=no name=disk target=disk
set echo name=echo remember=yes target=echo
set remote bsd-syslog=no name=remote remote=0.0.0.0:514 src-address=0.0.0.0 \
    syslog-facility=daemon syslog-severity=auto target=remote
/system routerboard settings
set boot-device=nand-if-fail-then-ethernet boot-protocol=bootp cpu-frequency=\
    680MHz force-backup-booter=no silent-boot=no
set boot-device=nand-if-fail-then-ethernet boot-protocol=bootp cpu-frequency=\
    680MHz force-backup-booter=no silent-boot=no
/user group
add comment="" name=read policy="local,telnet,ssh,reboot,read,test,winbox,pass\
    word,web,sniff,sensitive,!ftp,!write,!policy"
add comment="" name=write policy="local,telnet,ssh,reboot,read,write,test,winb\
    ox,password,web,sniff,sensitive,!ftp,!policy"
add comment="" name=full policy="local,telnet,ssh,ftp,reboot,read,write,policy\
    ,test,winbox,password,web,sniff,sensitive"
/interface bridge settings
set use-ip-firewall=no use-ip-firewall-for-pppoe=no use-ip-firewall-for-vlan=\
    no
/interface ethernet switch port
set (unknown) vlan-header=leave-as-is vlan-mode=fallback
set (unknown) vlan-header=leave-as-is vlan-mode=fallback
set (unknown) vlan-header=leave-as-is vlan-mode=fallback
set (unknown) vlan-header=leave-as-is vlan-mode=fallback
set (unknown) vlan-header=leave-as-is vlan-mode=fallback
/interface l2tp-server server
set authentication=pap,chap,mschap1,mschap2 default-profile=\
    default-encryption enabled=no max-mru=1460 max-mtu=1460 mrru=disabled
/interface ovpn-server server
set auth=sha1,md5 certificate=none cipher=blowfish128,aes128 default-profile=\
    default enabled=no keepalive-timeout=60 mac-address=FE:6D:33:72:19:75 \
    max-mtu=1500 mode=ip netmask=24 port=1194 require-client-certificate=no
/interface pptp-server server
set authentication=mschap1,mschap2 default-profile=default-encryption \
    enabled=no keepalive-timeout=30 max-mru=1460 max-mtu=1460 mrru=disabled
/ip accounting
set account-local-traffic=no enabled=no threshold=256
/ip accounting web-access
set accessible-via-web=no address=0.0.0.0/0
/ip address
add address=192.168.88.1/24 broadcast=192.168.88.255 comment=\
    "default configuration" disabled=no interface=ether1 network=192.168.88.0
add address=10.36.253.170/29 broadcast=10.36.253.175 comment="" disabled=no \
    interface=ether1 network=10.36.253.168
add address=172.16.135.20/29 broadcast=172.16.135.23 comment="" disabled=no \
    interface=ether3 network=172.16.135.16
/ip dhcp-server config
set store-leases-disk=5m
/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB \
    max-udp-packet-size=512 servers=192.168.111.1
 /ip dns static
add address=192.168.88.1 comment="" disabled=no name=router ttl=1d
/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
    tcp-close-wait-timeout=10s tcp-established-timeout=1d \
    tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s \
    tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no \
    tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s
/ip firewall filter
add action=accept chain=input comment="default configuration" disabled=no \
    protocol=icmp
add action=accept chain=input comment="default configuration" disabled=no \
    in-interface=ether1
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=no ports=5060,5061
set pptp disabled=no
/ip hotspot service-port
set ftp disabled=no ports=21
/ip neighbor discovery
set ether1 discover=no
set ether2 discover=yes
set ether3 discover=yes
set ether4 discover=yes 
set ether5 discover=yes
/ip proxy
set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=no enabled=no max-cache-size=none max-client-connections=\
    600 max-fresh-time=3d max-server-connections=600 parent-proxy=0.0.0.0 \
    parent-proxy-port=0 port=8080 serialize-connections=no src-address=\
    0.0.0.0
/ip route
add comment="" disabled=no distance=110 dst-address=10.36.253.0/27 gateway=\
    172.16.135.17 scope=20 target-scope=10
add comment="" disabled=yes distance=1 dst-address=10.36.253.0/27 gateway=\
    172.16.135.17 scope=30 target-scope=10
/ip service
set telnet address=0.0.0.0/0 disabled=no port=23
set ftp address=0.0.0.0/0 disabled=no port=21
set www address=0.0.0.0/0 disabled=no port=80
set ssh address=0.0.0.0/0 disabled=no port=22
set www-ssl address=0.0.0.0/0 certificate=none disabled=yes port=443
set api address=0.0.0.0/0 disabled=yes port=8728
set winbox address=0.0.0.0/0 disabled=no port=8291
/ip socks
set connection-idle-timeout=2m enabled=no max-connections=200 port=1080
/ip traffic-flow
set active-flow-timeout=30m cache-entries=4k enabled=no \
    inactive-flow-timeout=15s interfaces=all
/ip upnp
set allow-disable-external-interface=yes enabled=no show-dummy-rule=yes
/mpls
set dynamic-label-range=16-1048575 propagate-ttl=yes
/mpls interface
add comment="" disabled=no interface=all mpls-mtu=1508
/mpls ldp
set distribute-for-default-route=no enabled=no hop-limit=255 loop-detect=no \
    lsr-id=0.0.0.0 path-vector-limit=255 transport-address=0.0.0.0 \
    use-explicit-null=no
/ppp aaa
set accounting=yes interim-update=0s use-radius=no
/queue interface
set ether1 queue=ethernet-default
set ether2 queue=ethernet-default
set ether3 queue=ethernet-default
set ether4 queue=ethernet-default
set ether5 queue=ethernet-default
/radius incoming
set accept=no port=3799
/routing bfd interface
set all comment="" disabled=no interface=all interval=0.2sec min-rx=0.2sec \
    multiplier=5
/routing bgp network
add comment="" disabled=yes network=10.36.253.168/29 synchronize=yes
add comment="" disabled=yes network=172.16.135.16/29 synchronize=yes
/routing bgp peer
add address-families=ip as-override=no comment="" default-originate=never \
    disabled=yes hold-time=3m in-filter=ospf-in instance=default multihop=no \
    name=TortosaINSEbreRd2 nexthop-choice=default out-filter=ospf-out \
    passive=no remote-address=172.16.135.17 remote-as=65531 \
    remove-private-as=no route-reflect=no tcp-md5-key="" ttl=1 use-bfd=no
/routing filter
add action=accept chain=ospf-out comment="" disabled=no invert-match=no \
    prefix=10.0.0.0/8 prefix-length=8-32
add action=discard chain=ospf-out comment="" disabled=no invert-match=no
add action=accept chain=ospf-in comment="" disabled=no invert-match=no \
    prefix=10.0.0.0/8 prefix-length=8-32
add action=reject chain=ospf-in comment="" disabled=no invert-match=no
/routing mme
set bidirectional-timeout=2 gateway-class=none gateway-keepalive=1m \
    gateway-selection=no-gateway origination-interval=5s preferred-gateway=\
    0.0.0.0 timeout=1m ttl=50
/routing ospf interface
add authentication=none authentication-key="" authentication-key-id=1 \
    comment="" cost=10 dead-interval=40s disabled=no hello-interval=10s \
    instance-id=0 interface=ether1 network-type=broadcast passive=no \
    priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=none authentication-key="" authentication-key-id=1 \
    comment="" cost=10 dead-interval=40s disabled=no hello-interval=10s \
    instance-id=0 interface=ether2 network-type=broadcast passive=no \
    priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=none authentication-key="" authentication-key-id=1 \
    comment="" cost=10 dead-interval=40s disabled=no hello-interval=10s \
    instance-id=0 interface=ether3 network-type=broadcast passive=no \
    priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
add authentication=none authentication-key="" authentication-key-id=1 \
    comment="" cost=10 dead-interval=40s disabled=no hello-interval=10s \
    instance-id=0 interface=ether4 network-type=broadcast passive=no \
    priority=1 retransmit-interval=5s transmit-delay=1s use-bfd=no
/routing ospf network
add area=backbone comment="" disabled=no network=10.36.253.168/29
add area=backbone comment="" disabled=no network=172.16.135.16/29
/routing rip
set distribute-default=never garbage-timer=2m metric-bgp=1 metric-connected=1 \
    metric-default=1 metric-ospf=1 metric-static=1 redistribute-bgp=no \
    redistribute-connected=no redistribute-ospf=no redistribute-static=no \
    routing-table=main timeout-timer=3m update-timer=30s
/store
add comment="" disabled=no disk=system name=web-proxy1 type=web-proxy
/system clock
set time-zone-name=manual
/system clock manual
set dst-delta=+00:00 dst-end="jan/01/1970 00:00:00" dst-start=\
    "jan/01/1970 00:00:00" time-zone=+00:00
/system console
add disabled=no term=vt102
/system health
set
/system identity
set name=TortosaAlcanyiz26_T2
/system logging
add action=memory disabled=no prefix="" topics=info
add action=memory disabled=no prefix="" topics=error
add action=memory disabled=no prefix="" topics=warning
add action=echo disabled=no prefix="" topics=critical
/system note
set note="" show-at-login=yes
/system ntp client
set enabled=no mode=broadcast primary-ntp=0.0.0.0 secondary-ntp=0.0.0.0
/system upgrade mirror
set check-interval=1d enabled=no primary-server=0.0.0.0 secondary-server=\
    0.0.0.0 user=""
/system watchdog
set auto-send-supout=no automatic-supout=yes no-ping-delay=5m watch-address=\
    none watchdog-timer=yes
/tool bandwidth-server
set allocate-udp-ports-from=2000 authenticate=no enabled=yes max-sessions=100
/tool e-mail
set from=<> password="" server=0.0.0.0:25 username=""
/tool graphing
set page-refresh=300 store-every=5min
/tool mac-server
add disabled=no interface=ether2
add disabled=no interface=ether3
add disabled=no interface=ether4
add disabled=no interface=ether5
/tool mac-server ping
set enabled=yes
/tool sms
set allowed-number="" channel=0 keep-max-sms=0 receive-enabled=no secret=""
/tool sniffer
set file-limit=10 file-name="" filter-address1=0.0.0.0/0:0-65535 \
     filter-address2=0.0.0.0/0:0-65535 filter-protocol=ip-only filter-stream=\
    yes interface=all memory-limit=10 memory-scroll=no only-headers=no \
    streaming-enabled=no streaming-server=0.0.0.0
/user aaa
set accounting=yes default-group=read interim-update=0s use-radius=no

Alternativa amb NAT

TODO:

Jo configuro l'encaminador amb una configuració idèntica a la que fem amb un enllaç WDS, amb una adreça 172.25.x.x/29 per tenir les quatre adreces que necessitem,

Això implica no tenir accés als equips d'enllaç ja que les adreces 172.25.x.x no es propaguen i solament podriem arribar al RSxxx. Per poder accedir-hi reservo una adreça del node amfitrió i la redirigeixo amb DNAT a la 172.25.x.x de l'equip que fa l'enllaç en mode pont.

D'aquesta manera solament consumin una adreça del node per enllaç i no hem de reservar altre rang 10.x.x.x .

Cada equip d'enllaç té un SNAT a la banda del seu node que és el seu gateway, així encara que es perdi l'enllaç tenim accés des del seu segment de xarxa encara actiu.????

Solament té un problema, si accedeixes del mateix node has de fer servir l'adreça 172.25.x.x ja que les IPs del mateix node no tenen aplicades les regles del SNAT. M'imagino que això es podria arreglar; però com sembla que no és la solució que finalment adoptarà tinc prou per accedir-hi en remot.

Així estan muntats els nodes de la UPC i funcionen força bé. Ara no podeu arribar, per fer una ullada, ja que estem pendents de enllaçar-los a la resta de la xarxa.

La configuració és senzilla. La configuració del WDS habitual s'aplica al ethx amb l'única diferència de la màscara /29 en lloc de la /30. Reserves l'adreça SNAT al DHCP i configures una línia del firewall. Finalment a l'equip d'enllaç li configures com default gateway l'adreça IP 127.25.x.x del ethx.

Exemple:

           Node A

10.139.37.225/27 xarxa del node A 172.25.40.184/29 xarxa enllaç (habitualment WDS)

wLan/Lan 10.139.37.226

eth2 --> 172.25.40.185 (on connectem l'enllaç) equip d'enllaç --> 172.25.40.186 gw 172.25.40.185

SNAT 10.139.37.227 --> 172.25.40.192 (tots els ports)

Protocol encaminament BGP as=26932 remote-as=22111 remote-address=172.25.40.189

Node B

10.139.38.0/27 xarxa del node B 172.25.40.184/29 xarxa enllaç (habitualment WDS)

wLan/Lan 10.139.38.1

eth4 --> 172.25.40.190 (on connectem l'enllaç) equip d'enllaç --> 172.25.40.189 gw 172.25.40.190

SNAT 10.139.38.2 --> 172.25.40.189 (tots els ports)

Protocol encaminament BGP as=22111 remote-as=26932 remote-address=172.25.40.186

Vegeu també

Enllaços externs