IMPORTANT: Per accedir als fitxer de subversion: http://acacha.org/svn (sense password). Poc a poc s'aniran migrant els enllaços. Encara però funciona el subversion de la farga però no se sap fins quan... (usuari: prova i la paraula de pas 123456)

Introducció

TODO

Pas a Pas

NOTA: Aquest exemple és un exemple fet a laboratori per fer proves de la creació d'un sistemes en explotació

La següent prova s'ha realitzat amb:

A l'exemple anomenarem als dispositius

  • A les RB1100AHx2 les anomenarem ROUTORTOSA1 i ROUTORTOSA2.
  • Als commutador DLINK els anomenarem SWTORTOSA01 i SWTORTOSA02

L'esquema de connexions és el següent:

TODO: Penjar esquema HA Tortosa guifi

En resum:

ROUTORTOSA1

BONDING
 ether1 --> Port 17 boca commutador SWTORTOSA01
 ether2 --> Port 17 boca commutador SWTORTOSA02

ROUTORTOSA2 (backup)

 ether1 --> Port 18 boca commutador SWTORTOSA02


SWTORTOSA01 i SWTORTOSA02

Tenen una troncal de VLANs (passen totes les vlan) amb LACP als ports 2 i 3. És a dir els ports 2 i 3 es connecten mutuàment als dos ports (primer cal 
configurar LACP per tal d'evitar crear un bucle)

Configuració dels DLINK:

TODO: Captures de pantalla
TODO: fitxers de configuració

Configuiració dels ROUTERS:

TODO: Captures de pantalla
TODO: fitxers de configuració

L'export del ROUTORTOSA1 (és un export compacte, ñes a dir només mostra allò que és diferent de la configuració per defecte):

/interface> export compact 
# jan/02/1970 15:34:12 by RouterOS 5.14
# software id = 27JE-3FNX
#
/interface bridge
add name=bridge_vlan1
/interface vrrp
add authentication=ah interface=bridge_vlan1 name=vrrp_guifi_gestio password=\
    1234 priority=200 version=2 vrid=112
/interface bonding
add link-monitoring=mii-type1 mode=active-backup name=bonding1_ether1-ether2 \
    primary=ether1 slaves=ether1,ether2 transmit-hash-policy=layer-2-and-3
/interface vlan
add interface=bonding1_ether1-ether2 name=vlan1_guifi_gestio vlan-id=1
add interface=bonding1_ether1-ether2 name=vlan1029_XOCTORTOSA vlan-id=1029
add interface=vlan1029_XOCTORTOSA name=vlan1_QinQ1029 vlan-id=1
/interface bridge port
add bridge=bridge_vlan1 interface=vlan1_guifi_gestio
add bridge=bridge_vlan1 interface=vlan1_QinQ1029 

 ...
 /ip address> export compact
# jan/02/1970 15:36:12 by RouterOS 5.14
# software id = 27JE-3FNX
#
/ip address
add address=192.168.88.1/24 comment="default configuration" interface=ether1
add address=192.168.115.1/24 interface=ether13
add address=10.38.141.65/32 interface=vrrp_guifi_gestio network=10.38.141.65
add address=10.38.141.66/27 interface=bridge_vlan1

L'export del ROUTORTOSA2:

/interface> export compact
# jan/02/1970 16:27:50 by RouterOS 5.14
# software id = KUWV-FVVF
#
/interface bridge
add l2mtu=1590 name=bridge_vlan1
/interface ethernet
set 2 speed=1Gbps
/interface vrrp
add authentication=ah interface=bridge_vlan1 name=vrrp_guifi_gestio pass
word=\
    1234 version=2 vrid=112
/interface vlan
add interface=ether1 l2mtu=1594 name=vlan1_guifi_gestio vlan-id=1
add interface=ether1 l2mtu=1594 name=vlan1029_XOCTORTOSA vlan-id=1029
add interface=vlan1029_XOCTORTOSA l2mtu=1590 name=vlan1_QinQ1029 vlan-id=1
/interface bridge port
add bridge=bridge_vlan1 interface=vlan1_QinQ1029
add bridge=bridge_vlan1 interface=vlan1_guifi_gestio 
/ip address> export compact
# jan/02/1970 16:29:13 by RouterOS 5.14
# software id = KUWV-FVVF
#
/ip address
add address=192.168.88.1/24 comment="default configuration" interface=ether1
add address=192.168.115.2/24 interface=ether13
add address=10.38.141.67/27 interface=vlan1_guifi_gestio
add address=10.38.141.65/32 interface=vrrp_guifi_gestio network=10.38.141.65

La següent és una captura de pantalla de com queda el tema.

GuifiBondingVRRPVLANSQinQBridge.png

Qüestions a tenir en compte

MTU

Cal augmentar el MTU de la interfície de Bonding al portar dins QinQ?

Segurament si (i també el MTU de les interfície reals que hi han darrera?), tot i que simplement afectarà (farà fragmentació IP) quan els paquets siguin encaminats i no pas enbridgats. El MTU de la interfície de 
Bonding es MTU nivell 3 i només s'aplica si s'arriba a encaminar, és a dir entre dispositius de la mateixa VLAN no passarà (s'aplica el MTU del bridge que  
és 65535 què és la mida màxima en bytes d'un paquet IPv4 i com els commutadors estan amb Jumbo frames cap problema.)

Per que quedi constància de les MTU que es poden modificar i les que no a una RB1100AHx2 (falta comparar amb un x86):

Es pot canviar el MTU de la interfície de bonding, no mostra però el L2MTU (potser cal fixar-se al L2MTU de les reals que hi ha darrera el bonding?)

RouterOSBondingDefaultMTU.png

A les interfícies reals apareix:

InterficieRealCOnnectadaACommutadorAbbJumboFrames.png

Aquí su pou canviar el L2MTU.

Proves fetes amb l'ordre ping:

  • El muntatge és exactament el de Telvent però en laboratori (2 commutadors DLINK i dos routerboards)
  • Connecto al port 22 del commutador principal (on està en explotació el fuetó de la XOC) una routerboard 450G per simular un QinQ
  • Li poso una IP de la vlan1 a la RB450G

A la routerboard:


A Masquefa han reportat problemes amb 4 bits del MTU que es perden i que el forçava a posar la interfície amb MTU a 1496. Pot ser que sigui per que està en capa 3 el anar d'una vlan a un altre (no es va poder activar el bridge) i aleshores si que afecta el MTU de la interfície de Bonding (està per defecte a 1500):

RouterOSBondingDefaultMTU.png

Al afegir l'opció horizon i fer funcionar els bridges suposo que aleshores no hi ha limit de MTU per a la fragmentació ja que els brdiges tenen el valor de L2MTU a 65535 que és la mida màxim d'un paquet IP i per tant cabrà qualsevol tipus de paquet.

Vegeu també MTU i IP Fragmentation.

Recursos:

Loops

Al fer els bridges per a unir les vlan QinQ als dos routers i tenir el sistema en alta disponibilitat es crear un loop que provoca una tormenta de paquets.

Cal tenir en compte les següents qüestions:

http://mum.mikrotik.com/presentations/CZ09/VLAN-Workshop-Prague-final.pdf

Es parla de problemes amb RSTP i interfícies que no siguin físiques:

The problems with multiple bridge and STP/RSTP seem to caused of un mature linux kernel 2.6 software.
The configuration works well, but the RSTP­ PVST (PVST=Per VLAN Spanning Tree), meaning Per Bridge Spanning Tree in ROS function would be 
great. Support for MST 802.1s Multiple Spanning Tree are needed.

Spanning Tree can only be used on bridges with physical and WDS interfaces --> A mi m'ha funcionat amb vlans (al menys sense commutadors per enmig). 
Potser un bug de versions antigues de RouterOS?

Cal tenir en compte que en el nostre cas el que estem "enbridgant" no són interfícies físiques tipus ether1, ether2 sinó vlans. He comprovat però que RSTP només amb dispositius Mikrotik (sense Commutadors pel mig) i enbridgant vlans funciona igual que enbridgant interfícies físiques (RouterOS_i_Spanning_Tree#3_routerboards_amb_bucle_i_vlans). En alguns llocs es comenta que hi ha commutadors que no saben llegir els paquets BPDU de RSTP quan estan en vlans:

"RSTP probably isn't working correctly anyway, as most switches won't interpret BPDUs received with VLAN tags."
http://forum.mikrotik.com/viewtopic.php?f=2&t=41263

Es parla de problemes amb RSTP. Una solució plantejada és utilitzar l'opció horizon ([1], [2]).

Vegeu també bucles i RSTP.

Vegeu també

Enllaços externs